"RFC 2731: "The requestBody is only supported in HTTP methods where the HTTP 1.1 specification RFC7231 has explicitly defined semantics for request bodies". A própria RFC 2731 menciona que o verbo DELETE não possui uma semântica definida, o que levanta..."1 tabcoin · 0 comentário · Kvojps · 2 anos atrás
"Meus 2 cents: https://restfulapi.net/rest-api-best-practices/ "...2. Use HTTP Methods Correctly RFC 7231 and RFC 9110 define and discuss the use of HTTP methods to represent different types of actions that can be requested over HTTP. These RFCs also di..."1 tabcoin · 0 comentário · Oletros · 2 anos atrás
"Aqui nossos devs que entram depois precisam se ajustar e seguir o padrão da arquitetura original do sistema, se nao for assim vira bagunça."1 tabcoin · 0 comentário · welovetech · 2 anos atrás
"Também não entendi o por que nao seria. Tem alguma explicação técnica?"1 tabcoin · 1 comentário · welovetech · 2 anos atrás
"Normalmente vejo que DELETE com corpo de requisição não é uma boa prática Por que não seria? É a mesma coisa de um post para criação de models em massa"1 tabcoin · 3 comentários · silvestrini · 2 anos atrás
"Cara, muito obrigado por teres feito escrito essa explicaçao, não só é útil para o cara que disse não entender mas para outros como também. E ainda estou com uma dúvida, as pessoas tendem a não confiar muito MySql(não sei o motivo) mas a Uber que é uma..."1 tabcoin · 0 comentário · keithdimeni · 2 anos atrás
"Normalmente vejo que DELETE com corpo de requisição não é uma boa prática, consegue me passar uma referência sobre a relação dessa prática ser aderente ao Restful?"1 tabcoin · 6 comentários · Kvojps · 2 anos atrás
"Acredito que uma abordagem mais próxima dos ensinamentos do Restful seria method: DELETE URI: /categories e ai mandar os ID's no corpo da requisição. Daí voce vai ter flexibilidade Um item: Você pode enviar o corpo da requisição com apenas um ID, como:..."2 tabcoins · 7 comentários · DevDoug · 2 anos atrás
"Cara, ja consegui rodar Ollama satisfatoriamente bem (melhor do que quando tentei pela CPU) em um hardware inferior em RAM, utilizando a iGPU ao invés da CPU. segui parte deste tutorial da Intel https://www.intel.com.br/content/www/br/pt/content-detail..."1 tabcoin · 0 comentário · tietry · 2 anos atrás
"Cara, minha opinião baseado na pouca experiência que tenho. Atualizar versão do php é essencial, as novas versão melhora desempenho, segurança, novas funcionalidades e afins. Sobre migrar pra laravel, tem muita coisa que pode pesar. Onde trabalho todos..."2 tabcoins · 0 comentário · renanfa · 2 anos atrás
"Sempre teremos alguém como inspiração, mas não podemos esquecer de onde viemos e o quanto já conquistamos."2 tabcoins · 1 comentário · Marcellyavelino · 2 anos atrás
"Sim, usar o Docker foi de grande ajuda. Vi alguns comentários mencionando exatamente que essa mudança de versão é muito drástica, e isso é um fato. Chegamos a usar várias versões do PHP no Docker: 5.x, 6.x, 7.x, até chegar na última. Obviamente, foi o..."1 tabcoin · 0 comentário · allexcardos · 2 anos atrás
"Vamos entender esse artigo de forma bem simples, passo a passo. Vou usar comparações fáceis para te ajudar a visualizar como foi a atualização que o Uber fez no sistema de banco de dados deles. O que é um banco de dados? Um banco de dados é como um gra..."3 tabcoins · 1 comentário · LordGuido · 2 anos atrás
"O site não está abrindo, estou usando o chrome."0 tabcoin · 1 comentário · batataQuente · 2 anos atrás
"Interessante o conceito. Não conhecia. Obrigado por compartilhar. Surgiu uma dúvida... Se a string de Idempotencia é gerada com base no payload, ou seja, ela muda somente quando o payload muda, como funciona no caso de payloads (desejadamente) iguais?..."3 tabcoins · 1 comentário · bruamado · 2 anos atrás
"Legal a sacada de usar o Docker para simular, vou tentar fazer isso aqui! seu comentário foi muito bom, algo que me perguntava era sobre o tempo também de ir por um caminho ou outro, você respondeu isso muito bem, obrigado por compartilhar sua experiên..."1 tabcoin · 1 comentário · Kevyn · 2 anos atrás
"Obrigado pelas dicas, pois é vejo todo mundo usando composer hoje em dia no PHP, ainda estou aprendendo sobre ele também, pois não tem nos sistemas antigos aqui, Terraform já ouvi falar também, vou atrás de aprender mais sobre ele. obrigado!"1 tabcoin · 0 comentário · Kevyn · 2 anos atrás
"hum entendi, obrigado pela dica, não tenho conseguido estudar tanto como antes por conta da faculdade, vou aproveitar o recesso do fim de ano para dar um gás!"1 tabcoin · 0 comentário · Thurue · 2 anos atrás
"Obrigado pelo comentário, faz todo sentido, provavélmente o usuário nem iria perceber o Laravel mesmo, ainda estou aprendendo para que serve esse framework."1 tabcoin · 1 comentário · Kevyn · 2 anos atrás
"Muito obrigado pelo incetivo, vou começar sem medo. Você tem algum material ou curso para me indicar?"1 tabcoin · 0 comentário · rogerr · 2 anos atrás
"Vou testar o Rider depois, mas vou começar pelo Vs Code mesmo, obrigado pela dica! Tem algum material ou curso para me indicar?"1 tabcoin · 0 comentário · rogerr · 2 anos atrás
"Evolua a complexidade dos projetos. Se você quiser estudar Laravel para valer, se tornar especialista nele, pode considerar que tem alguns anos de conteúdo pela frente só pra isso. Você só sente que não evolui porque permanece na sua zona de conforto"1 tabcoin · 1 comentário · silvestrini · 2 anos atrás
"Não troque de curso, está quase terminando. Estude mais programação backend e vá atrás de um trabalho como junior, esqueça estágio. Mais faculdade não vai te transformar em programador, e fazer só por estágio também não vale a pena. É um tempo desperdi..."1 tabcoin · 0 comentário · silvestrini · 2 anos atrás
"Deixar aqui meu relato que também está no Tab News, sobre algo parecido que passei, sempre bons feedbacks, e no primeiro feedback mais fraco, demissão. https://www.tabnews.com.br/sterbe/o-desespero-de-entrar-no-mercado-pode-te-fazer-tomar-pessimas-deci..."1 tabcoin · 0 comentário · sterbe · 2 anos atrás
"PHP e JavaScript pra você que já tem experiência com web, é uma boa. Depois que estudar bem, parte para o Laravel e NodeJs pra ser fullstack. Recomendo entrar em comunidades do discord da galera que está estudando e tirar suas dúvidas. Alguns servidore..."1 tabcoin · 0 comentário · silvestrini · 2 anos atrás
"O segredo é equilibrar: IA dá os ingredientes, mas a receita final é a gente que tempera(⌐■_■)."1 tabcoin · 1 comentário · JoaoNaza · 2 anos atrás
"Estou vendo um pouco atrasado, então vou incluir a resposta mais detalhada na nova postagem que vou fazer, mas resumindo: pretende que o usuário suba uma ia qualquer do huggiefaces? Sim e não, hehe. pode linkar na página principal a fonte do modelo que..."1 tabcoin · 0 comentário · EduardoWorrel · 2 anos atrás